Vortrag Cloudecosystem Winter Summit

Am 22.01. habe ich am gemeinsam mit Herrn Michael Stegmann von Noxum und meinem Kollegen Lars Schmoldt am Cloudecosystem Winter Summit teilgenommen. Unsere Abteilung bei Microsoft sponsored die Veranstaltung und wir haben auf dem Event einen gemeinsamen Vortrag zum Thema “Entwicklung von neuen Geschäftsmodellen in der venetzten Welt” gehalten.

Insbesondere Herr Stegmann hat großes Lob für Zitat “seinen ehrlichen und praxisnahen Vortrag” bekommen.

Subsumarum habe ich versucht darzustellen, dass wir bei Microsoft mit unserer Azure Cloud Computing Plattform zunehmen Traktion gewinnen durch Partner, die eine Cloudlösung mit Hilfe unserer Technologie entwickeln. Wir sehen, dass sich dieser Trend verstärkt und bauen daher die Unterstützung von Cloudpartner weiter aus indem wir mehr Mitarbeiter im Business Development aufbauen und uns zusätzliche Instrumente für die Unterstützung der Partner schaffen.

Herr Stegmann hat denn im Hauptteil des Vortrages ausgeführt, warum Noxum sich entschieden hat in das Thema Cloud Computing zu investieren und Kompetenz in dem Feld aufzubauen. Warum sie sich bewusst für Azure entschieden haben und ihr hauseigenes Produkt cloudfähig und auf Azure lauffähig weiterentwickelt haben. Zudem hat er eindrucksvolle Kundenbeispiele, wie die Stiftung Warentest genannt, bei denen Noxums Kompetenz und Technologie zum Einsatz kommt. 

Unter folgendem Link kann man sich die Aufnahme unserer Präsentation ansehen.

Irgendwie komisch sich selber sprechen zu sehen und man sieht, dass ich an dem Tag zu früh aufgestanden bin. Aber optisch und akustisch sehr schön aufbereitet.

Vielen Dank möchte ich noch an Herr Türling und das Team von Cloudecosystem aussprechen die einen wunderbaren Event organisert haben und für den die T-Systems und Herr Hülsmann als Gastgeber in der Hauptstadtrepräsentanz der Deutschen Telekom einen wunderbaren Rahmen geschaffen haben.

Advertisements
Veröffentlicht unter Allgemein | Kommentar hinterlassen

FTP Zugriff auf Azure Websites

Weil mich gerade ein Partner danach gefragt hat, hier noch mal ein schnelles HowTo, wie man Zugriff via FTP auf eine Azure Website bekommt.

Auf dem Azure Management Portal

clip_image002

Auf der rechten Seite können Sie die Azure Deployment Credentials verändern bzw. beim ersten Mal festlegen.

clip_image004

Das sind andere Credentials als die Credentials, die bei der Anlage auf Basis eine Templates (Joomla, WordPress, whatever) vergeben werden (das waren die internen Credentials des 3rd Party Tools/CMS etc).

clip_image006

Es erscheint folgender Dialog mit User und Password.

image

Wichtig zu wissen ist, dass der FTP User aus „Website Name“ (meine URL ist http://agenturtag.azurewebsites.net/) und dem o.a. usernamen besteht. Daran bin ich auch schon mal hängengeblieben.

image

image

image

Bei einem FTP Tool muss man ggf. auf Passive Mode gehen. Zumindest war das für mich schon mal ein Workaround.

Ich hoffe, das hilft weiter.

Veröffentlicht unter Allgemein | Kommentar hinterlassen

Internet Explorer does not follow links

I just lifted another mystery in the Windows World and quickly wanted to share what I learned.

On one of my machines I had the problem, that Internet Explorer did no longer follow links. I was able to open IE, browse a URL, but when I clicked a link nothing happend. If I right clicked the link and selected “open in new tab” it did.

I had this issue for quite some time and was never able to resolve it. Today I inspected with ProcMon what happens when I click a specific link and compared the capture with another machine that is on the same patching level and did not habe the problem. There is a lot going on in the registry but on line looked different and suspicious. On the damaged machine it showed an “access denied” on mshtml.tlb while on the other machine it showed a “name not found”. When I inspected the files I found that the damaged machine had an mshtml.tlb with 1 kB size while the healthy machine had a file with 2,5 MB size.

Copying mshtml.tlb from the healthy machine did resolve my problem.

I am not sure, what caused the problem though. SC Endpoint says the machine is virus free and I just recently hit this specific machine with a couple of root kit detection tools and SpyBot. I experienced a couple of self inflicted unclean shut downs of the machine. Maybe that was the reason.

I hope this helps if you encounter the same problem. My OS version is the latest Windows 8.1 Pro as of today.

Veröffentlicht unter Computer und Internet, Windows 7 | Kommentar hinterlassen

Playing with VPN on Azure

Ich hatte vor einiger Zeit schon mal ausprobiert mit einem normalen Windows Server und der RAS Rolle ein VPN innerhalb von Azure aufzubauen und ich bin dabei in ein Zertifkatproblem gelaufen. Ich hatte kürzlich etwas Zeit damit rumzuspielen und wollte hier meine Erkenntnisse teilen. Vielleicht hilft es jemandem weiter.

Ich habe mich an diesem Artikel entlang gehangelt. Es sind dort aber ein paar Details nicht ausführlich bzw. nicht dokumentiert.

http://blogs.msdn.com/b/lighthouse/archive/2013/07/30/how-deploy-sstp-and-l2tp-vpn-in-windows-azure-windows-server-2012.aspx

Beim SSL Zertifikat habe ich für meinen Fall direkt ein Zertifikat mit SelfSSL angelegt. Ich habe es in IIS eingetragen und insbesondere das alte Zertifikat gelöscht. Das vorhandene Default Zertifikat lässt sich nicht exportieren. Lässt man es aber eingetragen, wird es verwendet, wenn sich der Client anmeldet und dann passt das natürlich nicht zum Zertifkat das später auf den Client geladen wird. Das war der Grund warum mein erster Anlauf fehlgeschlagen war.

Das nächste was ich anders gemacht habe / machen musste … in Schritt 4 … war auf dem VPN Server EAP auszuschalten.

clip_image001

Sonst kommt es im VPN Client zu einer Fehlermeldung, zu der im Web Hinweise standen, dass der Server nur MS-CHAP v1 anböte, was unsicher sei. Also habe ich erst die anderen Protokolle auch zugelassen (PAP und CHAP … dann ging es schon) und der Reihe nach alle Protokolle außer MS-CHAP v2 ausgeschaltet. Das ging dann auch.

In Schritt 6 in der Client Configuration ist dann wichtig das Zertifkat in den Trusted Root Certificate Authorities Store des Local Computers einzutragen. Packt man das Zertifikat in den Store des Users wird es nicht gefunden.

Danach hat bei mir der Tunnel funktioniert.

Ich habe dann den Tunnel noch über den Task Scheduler und rasdial.exe automatisch beim Computerstart aufbauen lassen.

clip_image003

Dann habe ich den Client durch den Tunnel in die Domäne genommen.

Das hat zwar geklappt aber bei mir war es dann noch nicht möglich den Client über seinen Namen über den Tunnel aufzulösen und da der Client bei jedem Boot in meiner Konfiguration eine neue IP bekommt ist das noch ein Problem.

Ich habe also den Client gezwungen, die VPN Connection beim DNS zu registrieren und dann ging es auch den Rechner über den Namen aufzulösen.

Das kann aber auch ein Ungedulds – / Timing Problem auf meiner Seite gewesen sein. Sprich, wenn ich alles gebootet und etwas gewartet hätte, hätte es vielleicht auch so geklappt.

Mein VPN Server ist Domain joined im eine VNET mit dem DC.

In der Firewall des W8.1 Clients aus der Azure Gallery habe ich noch Echo zum pingen und SMB für File Shares jeweils für das Domain Netzwerk geöffnet.  

Das VPN habe ich auf meinem lokalen Rechner ebefalls eingerichtet. Somit konnte ich den Client und den VPN Server booten, direkt den VPN Tunnel auf meinem lokalen Rechner aufbauen und darüber auf alle Server und den Client zugreifen inklusive Remote Desktop ohne noch mal von außen auf die VMs (insbesondere den Client) zugreifen zu können. Der Client ist in einer anderen Subscription und könnte also auch in einem anderen DC sein etc.

Wie gesagt … vielleicht hilft es jemandem.

L2TP habe ich nicht ausprobiert.

Veröffentlicht unter Azure | 1 Kommentar

Kenwood KA-660 rechter Kanal geht nicht mehr

Fehlersuche und Reparatur – für meinen Fall

Vor ein paar Tagen wollte ich meinen alten (und allerersten und einzigen) Hifi-Verstärker verwenden um etwas Musik zu hören. Das Gerät steht mittlerweile in der Kellerbar die auch gleichzeitig Saunaraum ist und wird nur bei Parties, beim Saunen oder bei WP_20140520_15_22_23_Progelegentlich anderen Arbeiten im Keller verwendet.

In der Vergangenheit plagten das Gerät schon häufiger die üblichen Staubprobleme. Insbesondere der Tone-Schalter und die Tape-Schalter scheinen bei diesem Kenwood recht anfällig zu sein, aber ich dachte eigentlich, dass hätte ich nach der letzten Behandlung mit KONTAKT CHEMIE TUNER 600 in den Griff bekommen. Nun kam auf einmal aus dem rechten Kanal nur noch kratzende Musik und es hörte sich an, als ob nur noch die Spitzen der Amplituden einen lose Kontaktstelle überwinden können.

Zunächst habe ich die oben erwähnten üblichen Problemzonen überprüft und auch die Lautsprecherwahltaster und die Lautsprecherkabel geprüft. Daran lag es nicht. Dann habe ich das Internet bemüht und 2 Hinweise gefunden, die ggf. hätten relevant sein können.

WP_20140520_14_17_41_ProDer eine war, dass die Lautsprecherwahltaster defekt sein könnten. Ich habe diese geprüft, gereinigt und bin leider erst nach dem Auslöten und Öffnen von den beiden Schaltern drauf gekommen, dass ich erst mal die Gegenprobe mit dem zweiten Paar und dem zweiten Schalter hätten machen sollen. Denn dann hätte ich gewußt, dass es das nicht war. Vom Zerlegen des Lautsprecherwahltasters beim KA-660 kann ich nur abraten. Darin sind 4 Schleifkontakte, die eigentlich kleine Metallfedern sind und eine Feder mit einem Ausrücker. Das alles wieder passig zusammenzubringen ist eine Arbeit für Uhrmacher und ich habe mehrmals eine der Federn plattgedrückt und hatte später fast schon aufgegeben den Schalter jemals funktionabel wieder zusammenbringen zu können. Einfach nicht nachmachen.

WP_20140520_14_14_38_ProDer zweite Hinweis war, dass das Lastrelais, das gleich neben den Lautsprecheranschlüssen ist ggf. nicht mehr richtig schließt. Jemand im Internet hatte suggeriert, dieses auszulöten, zu zerlegen (dafür WP_20140520_15_22_00_Promuss man es am Sockel aufsägen, nur mit dem Taschenmesser kommt man da nicht weiter) und dann die Kontakte zu säubern. Dreckig (schwarz) waren sie. Gebracht hat es aber nichts.

Dann hatte ich noch gelesen, dass manchmal nachlöten bestimmter Stellen helfen kann und ich hatte die Lasttransistoren im Verdacht, denn an den Stellen gibt es 2 Wiederstände, an denen die Platine schon ziemlich mitgenommen aussah. Also habe ich alle Transisitoren nachgelötet. Wieder nichts. Beim Testbetrieb ist mir dann die Idee gekommen die alte Taktik des Abklopfens zu verwenden. Das macht man wohl auch bei Röhrenverstärkern, um defekte Röhren zu finden. Aber generell, wenn irgendwas einen Wackelkontakt hat, kann abklopfen mit einem isolierten mittelschweren Gegenstand (Schraubendrehergriff) schon mal eine grobe Richtung weisen. WP_20140520_14_17_28_ProDabei hat sich herausgestellt, dass Klopfen gegen den Kühlkörper das Kratschen verändert und manchmal auch zufällig den Ton komplett sauber werden lässt. Die Endstufentransistoren konnten es aber wohl nicht sein, es sei denn einer wäre kaputt oder ein Beinchen am Gehäuse des Transisitors locker gewesen. Weiteres Klopfen hat mich dann auf die senkrecht eingelötete Platine der Klangregelung gebracht. Dort war die Veränderung am größten (aber auch nicht wirklich eindeutig). Also habe ich die Platine mit TUNER 600 bearbeitet und für eine halbe Minute war dann beim Ausprobieren der Ton wieder OK. Aber nach kurzer Zeit dann doch wieder kratzig. Also habe ich zu gröberen Mitteln gegriffen und die nicht ganz einfach zugängliche Platine mit einer Zahnbürste gereinigt. Das habe ich im Betrieb gemacht und dabei ist mir aufgefallen, dass an einer Stelle deWP_20140520_14_05_19_Pror Ton kurz besonders schnell gut geworden ist und dann aber auch total ausgefallen war. Abtasten mit dem Finger hat mich dann darauf gebracht, dass sich ein Transistor fast komplett aus den Lötstellen gelöst hatte und frei beweglich war. Das war dann der Übeltäter. Auf dem Bild rechts sieht man noch am rechten Transistor, wie er verlötet war bevor ich nachgelötet habe.WP_20140520_14_16_38_Pro Die anderen 4 Lötaugen links sind da schon nachgelötet gewesen. Insgesamt sind in der Klangregelung, ich glaube, 8 Transistoren je Kanal verbaut. Davon 4 größere und 4 etwas kleinere mehr zur Mitte der Platine hin. Die jeweils 4 großen äußeren waren im Vergleich zu allen anderen Bauteilen sehr schlecht verlötet, was vielleicht an der Form der Beinchen liegt. Diese sind wie klassiche Transistoren recht dünn und eher quadratisch und nicht etwas breiter wie ein kleines Band wie bei anderen Bauteilen teilweise üblich. Nachlöten dieser dann in Summe 8 äußeren Transistoren hat dann den Fehler komplett behoben.

Das ganze hat mich sicher 8-10 Stunden Arbeit für die Fehlersuche gekostet. Aber jetzt funktioniert alles wieder einwandfrei.

Veröffentlicht unter Allgemein | 3 Kommentare

Windows 8.1 is waking up during the night due to regular maintenance.

I had another of these “Windows suddenly starts waking up in the night and I don’t know why” events.

After going down the regular paths:

  • powercfg –lastwake (+ devicearmed etc)
  • exporting schtasks to XML to get verbose output and seeing through it in Excel
  • disabling all tasks that were scheduled to wake the computer

my comnputer still woke up.

I found out that one task had been rearmed to wake the computer:
image
(this happened twice … I disarmed “wake computer”, the computer still woke and the task had the option set after that again).

I searched the web a little and found this post on MSFT support:
http://support.microsoft.com/kb/2799178

It seems like there is a setting in Action Center that overrules what is set in the in Task Scheduler:
image
image
image

I hope disabling this finally fixes my problem. If you have other suggestions … let me know int the comments.

I just saw, that my other workstation also wakes in the night but hibernates one hour later which is why I didn’t realize it wakes. I did not set this up manually, so the setting must habe changed in the time between end of december and know because of an update.

Veröffentlicht unter Allgemein | 1 Kommentar

HEXXIT Server auf Windows Azure (Windows Version)

Mein Neffe hat mich gefragt, ob man nicht einen Hexxit Server in der Cloud betreiben könne. Ich würde doch da bei einer Firma arbeiten, die so was anbietet … Winking smile

Also habe ich mal schnell einen entsprechenden Server hochgezogen, was an sich auch kein Hexenwerk ist. Anbei eine kurze Beschreibung (Ich habe keinen Minecraft Account … kann es also selber nicht ausprobieren, aber mein Neffe konnte danach den Server einsetzen):

Windows Azure Abonnement beschaffen

Zunächst einmal benötigt man Zugang zur Windows Azure Platform. Also muss ein Trial Account angelegt werden, wie hier beschrieben:
Windows Azure Websites Einstiegs Tutorial
… bis zum Schrit “Dort haben sie 150 Euro und 30 Tage frei” durchführen.

Einen Windows Server erstellen und starten

Dazu am Windows Azure Management Portal anmelden unter manage.windowsazure.com

image

Dort einen neuen Server erstellen:

image

image

image

image

image

Username und Passwort sollten sicher sein!

image

Der Cloud Services DNS Name muss unique sein in der Windows Azure Platform. Als Datacenter eines in der eigenen Region wählen. Storage Account generieren lassen. Den Cloud Service neu erstellen lassen. (Das legt unter anderem den DNS Namen fest bzw. einen neuen an).

image

Remote Powershell brauchen wir nicht –> Entfernen.

image

Danach warten (einige Minuten) bis der Server gestartet ist.

Nun den Server auswählen aus der Server Liste (sollte ja nur einer enthalten sein).

image

Tab Endpoints auswählen (hätte ich auch schon oben machen können).

image

image

image

image

image

Damit haben wir im Windows Azure Load Balancer bekannt gegeben, dass dieser Server genauer diese Virtuelle Maschine über Port 25565 von außen erreichbar ist. Dies ist der Standard Port für einen Hexxit Server.

Arbeiten auf dem Server

Nun Verbinden wir uns zum Server:

image

image

image

Das RDP File am besten auf den Desktop speichern. Man kann es auch direkt öffnen, aber ich passe in der Regel erst die Auflösung an, da diese per default Fullscreen ist und das gefällt mir nicht für Remote Server.

Rechtsklick auf das RDP File –> Edit.

image

image

image

image

image

image

image

image

image

Im Server Manager schalten wir für den Internet Explorer die Enhanced Security ab.

image

image

image

Die Maus unten rechts in den Bildschirmwinkel der Session verschieben … das bringt die Charms zur Anzeige.

image

Wir suchen, finden und starten den Internet Explorer.

image

Pinnen ihn an die Taskleiste.

image

image

verwenden die Recommended Settings

Vorausssetzung Java

Für Hexxit brauchen wir eine Java Installation auf dem Server. http://www.oracle.com/technetwork/java/javase/downloads/index.html

Ich habe das JDK installiert.
image

Cut and Paste funktioniert einwandfrei mit RDP. Also Link oben kopieren und in den IE in der RDP Session kopieren:

image

image

image

image

image

imageimageimageimage

Hexxit Server “installieren”

Nun laden wir den Hexxit Server herunter.

Sowie den Hexxit Server:
http://www.technicpack.net/hexxit#
Download Hexxit 1.0.10 Server
http://mirror.technicpack.net/Technic/servers/hexxit/Hexxit_Server_v1.0.10.zip

image

image

image

neuen Ordner für die Server Software anlegen:

image

Dateien kopieren

image

image

Server Properties ggf. anpassen … Rechtsklick … OpenWith …

image

image

Die Server IP muss nicht eingetragen werden (da gab es andere Hinweise in Blogs, die ich bei der Recherche gefunden hatte.)

image

Port in der lokalen Firewall öffnen

Windows Firewall konfigurieren um Kommunikation über den Default Port von Hexxit zuzulassen. Control Panel wieder über die Charms aufrufen:

image

image

image

image

image

image

image

image

image

image

image

Hexxit Server starten

Server starten mit Doppelklick auf

image

image

image

Die System Overload Meldung kann daher rühren, dass noch der .NET Optimization Service läuft. Es dauert einige Minuten, bis die Optmierung gelaufen ist. Danach ist dann genug CPU für den Server übrig.

image

Manchmal kommt es vor, dass der Server meldet, er können den Port nicht belegen. Das liegt vermutlich daran, dass die Java Engine nicht sauber heruntergefahren wurde. Dann kann man entweder alle Java Tasks beenden über den Task Manager oder Sysinterals Process Explorer (muss man dann vorher herunterladen) oder den Server einmal booten. Danach sollte der Hexxit Server wieder normal starten. Ist bei mir aber nur einmal vorgekommen.

Booten funktioniert über die Charms im Windows Server oder „von außern“ über das Windows Azure Management Portal.

Public IP ablesen

Der Hexxit Client benötigt eine IP Adresse um sich zu verbinden. Dies bekommt man über das Windows Azure Management Portal manage.windowsazure.com wie folgt:

image

rechts in der Mitte gibt es den Eintrag.

image

Die IP Adresse kann sich ändern, wenn die virtuelle Maschine auf einen anderen Host umgezogen wird. Dann lässt sie sich einfach über die Kommando Zeile wie folgt ermitteln:

image

Server stoppen um Ressourcen zu schonen

Die virtuelle Maschine kann, wenn sie nicht benötigt wird, gestoppt werden. Beim erneuten Starten, bootet der Server. Das bedeutet, dass man sich erneut über RDP verbinden muss und den Hexxit Server über die launch.bat Datei erneut starten muss. Oder man automatisiert das durch einen Eintrag in einer der Autostart Möglichkeiten unter Windows (Registry, Task Scheduler, Autostart Ordner).

Gestoppt wird im Management Portal hier:

image

Ist der Server gestoppt, erzeugt er keine Compute Kosten mehr. Jedoch verbraucht die gespeicherte Festplatte (virtual disk) noch Kosten. Diese sind aber minimal im Vergleich zu den Compute Kosten.

Löschen kann man den Server wie folgt:

image

image

Mit “delete the attached disks” wird die C-Platte der virtuellen Maschine gelöscht. Sprich … danach ist alle Arbeit verloren! Mit “keep the attached disks” bleiben die Platten (hier die C-Platte) erhalten und es kann ein neuer Server mit der Disk aufgesetzt werden. Die Kosten sind die selben wie durch einen “Shutdown”.

Kosten

Nachdem die Trial Periode abgelaufen ist, kann man im Billing Bereich des Abonements dieses weiterführen. Dann werden die geleisteten Dienste kostenpflichtig abgerechnet.
image

image

image

Was kostet mich der Server nach der Trial Periode?

Über den Pricing Calculator kann man sich das ausrechnen:
http://www.windowsazure.com/en-us/pricing/calculator/

Im Grunde muss man 3 Faktoren berücksichtigen:

Compute Kosten

image

image

Storage Kosten für die “C-Platte” des Servers

image

image

Bandbreite
Das scheint zwischen 1 GB und 2 GB pro Tag zu liegen nach meinen kurzen Erfahrungen. Mich hat das etwas erstaunt, da normalerweise Multiplayer Games sehr wenig Bandbreite verwenden.

image

Das erscheint im ersten Moment teuer. Und man kann sicher bei diversen Hostern einen Server mit 4 Kernen und mehr Diskspace für ebenso 50 Euro bekommen. Aber in Windows Azure bezahlt der Kunde den Compute Anteil nur pro Minute (der Preis ist zwar pro Stunde angegeben aber es wird pro Minute abgerechnet).

Außerdem habe ich keinerlei Abnahmeverpflichtung während bei Hostern in der Regel 12 oder 24 Monate Laufezeitbindung besteht und eine Einrichtungsgebühr verlangt wird. Zudem kann ich super flexibel meinen Server verändern, weitere Server starten oder die Anzahl der Kerne für bestimmte Zwecke erhöhen. Zudem gibt es die kostenfreie Trial für einen Monat.

Mal angenommen es wird nur 4 Stunden am Wochentag abends und 12 Stunden am Wochenende gespielt. Dann sieht die Rechnung schon anders aus:

image

Wichtig ist, dass man den Server herunterfährt, um Kosten zu sparen.
image
Mit etwas Aufwand, kann man den Hexxit Java Server automatisch mit dem Booten des Servers starten und ein kleines Powershell Skript entwickeln, dass über die Windows Azure Management API den Server von der lokalen Konsole aus startet und stoppt.

Fazit

An sich alles kein Hex(x)enwerk und mit dem Trial Account kostenfrei für einen Monat. Vielleicht mal ein etwas anderes Übungsobjekt, um sich das Thema Cloud Computing zu erschließen und dem Minecraft verrückten Sprößling etwas Spass zu schenken.

P.S.:

Da ich keinen Minecraft Client habe, habe ich nach meinen Gedächtnis noch mal einen zweiten Hexxit Server hochgezogen um den Post zu erstellen und die Screenshots zu bekommen. Endpoint einrichten, Windows Firewall konfigurieren und dass der Java Prozess einmal den Port nicht wieder freigegeben hatte waren die einzigen Besonderheiten. Sollte ich dennoch was vergessen haben, bitte einen Kommentar hinterlassen.

Auf Linux würde das ganze Thema vergleichbar ablaufen und man könnte vermutlich alles über SSH erledigen. Vielleicht mache ich dazu noch mal einen weiteren Blogpost. Generell wäre ein Linux Server günstiger.

image

Ein anderer Diskussionspunkt wäre, ob nicht ein shared core ausreichend ist. Ich sehe bei wenigen Usern auf dem Server maximal 55% CPU Last. Ich könnte mir vorstellen, dass der Server auf einem shared core zu wenig CPU zur Verfügung hat. Müsste man aber ausprobieren.

P.P.S.: Hexxit als Dienst für automatischen Start registrieren

NSSM herunterladen
http://nssm.cc/download/?page=download

nssm in das Hexxit-Verzeichnis kopieren (ein anderer Ordner würde auch gehen).

image

nssm von der Konsole aus starten um einen Service zu registrieren

image

Name, Pfad und Startup Directory eingeben.

image

Install Service drücken

Kontrollieren ob der Dienst registriert wurde:
image

image

image

Testweise den Service starten

image

Gegebenenfalls im Taskmanager nachvollziehen, was / das etwas passiert. (Rechtsklick auf die Taskbar)

image

image

Das Server Log kontrollieren. Dazu eine Powershell Konsole starten

image

image

image

Server neustarten um den Autostart des Dienstes zu testen.

image

Fertig!

Jetzt ist kein manueller Eingriff mehr nötig um den Hexxit Server an sich zu starten. Ein einfaches Starten des Servers über das Azure Management Portal genügt und der Hexxit Server wird angekurbelt.

Veröffentlicht unter Allgemein | Kommentar hinterlassen